MULTI-ERROR...

Todo lo referente a temas de virtualizacion.. XenServer, VMWare

Moderadores: xavisan, xavisan

MULTI-ERROR...

Notapor tricix el Mié May 21, 2008 14:58

Que pasa gente... tengo un super pollo de la muerte.
Resulta que el servicio del virtualcenter, se detiene todo el rato. Creia que era por el tamaño de la DataBase, pero NO! Eso ha sido un efecto secundario. Resulta que el tablespace se esta llenando de eventos chungos de la muerte que genera el virtualcenter. Asi que de momento eliminamos la BBDD de la equación.

Datos que tengo:
- Cuando entro en un ESX, aparecen mensajes de logon login en las task... MUCHISIMOS.
- No tengo mas datos xD jajajajajajaja

Lo primero que voy a hacer es un UPGrade de la VirtualCenter de la 2.0.1 a la 2.0.2....

IDEAS???????
tricix
Senior
Senior
 
Mensajes: 63
Registrado: Vie Nov 30, 2007 09:26

Notapor xavisan el Mié May 21, 2008 17:46

Hola tricix,

Me podrías indicar que herrores te están apareciendo. ;-)
Un Saludo,
Xavi
Citrix CTP (2009-2016)- Microsoft MVP(2012-2014)
CCP APP&Desktop, CCA,CCEA, CCEE, CCIA, CCA XS Platinum,
CCA EdgeSight, CCA Provisioning Server, CCA XD Platinum

Imagen
Avatar de Usuario
xavisan
Moderator
Moderator
 
Mensajes: 4162
Registrado: Jue Oct 20, 2005 22:53
Ubicación: Montcada i Reixac (Barcelona)

Bueno....

Notapor tricix el Jue May 22, 2008 08:12

La cosa ha empeorado. No se si ha sido producto de lo mismo, pero uno de los ESX ha muerto. Ha caido esta noche. Unos de mis compañeros han pasado la noche aqui, asi que.... una fiesta.

Voy a realizar una select en la BBDD para ver que es lo que ha estado introducioendo los ultimos dos dias, ya que la tabla que llenava era la de events.

Resumiendo que el error que aparece en pantalla del esx es este:

irq: 1134: usurping irq 31 (prompt IO-APIC-level to vmnics-level)
irq: 1134: usurping irq 32 (prompt IO-APIC-level to vmnics-level)
irq: 1134: usurping irq 33 (prompt IO-APIC-level to vmnics-level)

I el error que aparecia en el Virtual Center era este:

The description for Event ID ( 1000 ) in Source ( VMware VirtualCenter Server ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Starting VMware VirtualCenter 2.0.1 build-32042.

I el otro que aparece todo el rato es el siguiente:

The description for Event ID ( 1000 ) in Source ( VMware VirtualCenter Server ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: An unrecoverable problem has occurred, stopping the VMware VirtualCenter service. Check database connectivity before restarting. Error: Error[VdbODBCError] (-1) "ODBC error: (HY000) - [Oracle][ODBC][Ora]ORA-01461: can bind a LONG value only for insert into a LONG column
" is returned when executing SQL statement "UPDATE VPX_HOST SET DATACENTER_ID = ? , DNS_NAME = ? , IP_ADDRESS = ? , USER_NAME = ? , PASSWORD = ? , PORT = ? , ENABLED = ? , VPXA_ID = ? , MASTER_GEN = ? , MASTER_SPEC_GEN = ? , VMOTION_ENABLED = ? WHERE ID = ?".
tricix
Senior
Senior
 
Mensajes: 63
Registrado: Vie Nov 30, 2007 09:26

Notapor tricix el Jue May 22, 2008 10:23

vim.event.UserLoginSessionEvent

He exportado los datos del tablespace del vmware.

Ese evento que te paso al principio a parece chorrocientas mil veces....
tricix
Senior
Senior
 
Mensajes: 63
Registrado: Vie Nov 30, 2007 09:26

Notapor xavisan el Jue May 22, 2008 16:47

Hola tricix,

Podrías indicarme que aparece en los siguientes logs??

/var/log/messages
/var/log/boot.log
/var/log/dmesg
/var/log/vmkernel
/var/log/vmkwarning

Parece un problema de dispositivo o de bus.

Sobre el evento 1000, podrías solucionarlo mediante REGEDIT,

En la clave de registro:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpxd.
Pulsas el botón izquierdo del ratón, en DependOnService pulsas modify y añades el servicio del nombre de la base de datos.

Ya me dirás que tal.
Un Saludo,
Xavi
Citrix CTP (2009-2016)- Microsoft MVP(2012-2014)
CCP APP&Desktop, CCA,CCEA, CCEE, CCIA, CCA XS Platinum,
CCA EdgeSight, CCA Provisioning Server, CCA XD Platinum

Imagen
Avatar de Usuario
xavisan
Moderator
Moderator
 
Mensajes: 4162
Registrado: Jue Oct 20, 2005 22:53
Ubicación: Montcada i Reixac (Barcelona)

Notapor tricix el Vie May 23, 2008 08:26

Buenos dias.... vamos a ir por partes... xD

Te cuento, el problema del esx era un problema de hw. Han cambiado la memory board y una tarjeta de red. El tema es que cuando tienes un problema de HW y apagas el servidor de manera incorrecta (como apagas el servidor bien, cuando tienes un problema de HW?????) se desconfiguró la secuencia de inici. (Palabras textuales del VMWare). Dicho esto el ESX vuelve a resurgir de sus cenizas, llamale fenix.... El VirtualCenter, ya es otra cosa.... sigo investigando...

Por cierto, servicio tecnico de VMWare, INCREIBLE! Con una aplicación para conectarse en remoto, infinitamente mejor que la usada por HP o otros....
tricix
Senior
Senior
 
Mensajes: 63
Registrado: Vie Nov 30, 2007 09:26

Notapor xavisan el Vie May 23, 2008 09:59

Hola tricix,

Me alegra de que el tema en este aspecto ya lo tengas resuelto, de hecho tenía mis sospechas, y por eso te pedía los correspondientes logs. ;-)

Tendremos que saber que aplicación están utilizando, jejejeje.
Un Saludo,
Xavi
Citrix CTP (2009-2016)- Microsoft MVP(2012-2014)
CCP APP&Desktop, CCA,CCEA, CCEE, CCIA, CCA XS Platinum,
CCA EdgeSight, CCA Provisioning Server, CCA XD Platinum

Imagen
Avatar de Usuario
xavisan
Moderator
Moderator
 
Mensajes: 4162
Registrado: Jue Oct 20, 2005 22:53
Ubicación: Montcada i Reixac (Barcelona)

Notapor tricix el Vie May 23, 2008 12:29

Si, la parte del host que murio, esta arreglada, pero la parte del virtual center, ni mucho menos. De exo han estado durante 2 horas enchufados en mi maquina i no sacan nada en claro. La verdad es que tiene mala pinta el asunto.

Perdona la ignorancia, pero lo que me has dicho que modifique del registro.... QUE HACE???????
tricix
Senior
Senior
 
Mensajes: 63
Registrado: Vie Nov 30, 2007 09:26

Notapor tricix el Vie May 23, 2008 23:51

Alucinante.... Sabeis cual era/es el problema????? La instalacion de los agentes de Open View.... Despues de dos largas charlas con los tecnicos de VMWARE (insisto, una atencion practicamente inmejorable. BRUTAL) hemos descubierto que eran los causantes de todos los logons del ROOT en los propios ESX i los que hacian que saltara el servicio del Virtual Center y como no, del volumen increible (50Mb/dia) que estaban escribiendose en la VirtualCenterDataBase....

Dudo que no se puedan instalar los agentes del open view, asi que en cuanto esté solucionado.... OS DIGO COMO! xD

Saludos.

Vaya peso me he quitado de encima... me estaba volviendo... mas tonto xD
tricix
Senior
Senior
 
Mensajes: 63
Registrado: Vie Nov 30, 2007 09:26

Notapor xavisan el Sab May 24, 2008 16:29

Hola,

tricix escribió:Si, la parte del host que murio, esta arreglada, pero la parte del virtual center, ni mucho menos. De exo han estado durante 2 horas enchufados en mi maquina i no sacan nada en claro. La verdad es que tiene mala pinta el asunto.

Perdona la ignorancia, pero lo que me has dicho que modifique del registro.... QUE HACE???????


Ello sirve para especificar el servicio del nombre de la base de datos. ;-) lo que haces es forzarlo de forma directa.
Un Saludo,
Xavi
Citrix CTP (2009-2016)- Microsoft MVP(2012-2014)
CCP APP&Desktop, CCA,CCEA, CCEE, CCIA, CCA XS Platinum,
CCA EdgeSight, CCA Provisioning Server, CCA XD Platinum

Imagen
Avatar de Usuario
xavisan
Moderator
Moderator
 
Mensajes: 4162
Registrado: Jue Oct 20, 2005 22:53
Ubicación: Montcada i Reixac (Barcelona)

Notapor xavisan el Sab May 24, 2008 16:31

Hola tricix,

tricix escribió:Alucinante.... Sabeis cual era/es el problema????? La instalacion de los agentes de Open View.... Despues de dos largas charlas con los tecnicos de VMWARE (insisto, una atencion practicamente inmejorable. BRUTAL) hemos descubierto que eran los causantes de todos los logons del ROOT en los propios ESX i los que hacian que saltara el servicio del Virtual Center y como no, del volumen increible (50Mb/dia) que estaban escribiendose en la VirtualCenterDataBase....

Dudo que no se puedan instalar los agentes del open view, asi que en cuanto esté solucionado.... OS DIGO COMO! xD

Saludos.

Vaya peso me he quitado de encima... me estaba volviendo... mas tonto xD


Este mismo problema existe en isntalaciones con XenApp o Presentation Server, dependiendo del proceso de instalación y cuando se ha realizado la instalación de dichos agentes, generan graves problemas en la granjas.

Me alegro de que esté detectado el problema y solucionado. :-)
Un Saludo,
Xavi
Citrix CTP (2009-2016)- Microsoft MVP(2012-2014)
CCP APP&Desktop, CCA,CCEA, CCEE, CCIA, CCA XS Platinum,
CCA EdgeSight, CCA Provisioning Server, CCA XD Platinum

Imagen
Avatar de Usuario
xavisan
Moderator
Moderator
 
Mensajes: 4162
Registrado: Jue Oct 20, 2005 22:53
Ubicación: Montcada i Reixac (Barcelona)


Volver a Software para Virtualizar

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados

cron